When your site is experiencing issues, it's important to identify the cause quickly to minimize disruption. This comprehensive guide will help you troubleshoot common problems and get your site back online.
Check your Website
The very first thing is to visit your website and see if it loads. If the website still does not load, here are a few things you may try:
Refresh the page
Check using a different browser or device
Restart the devices, including the router
Clear the cache and cookies
Have a friend or colleague connected to a different network check on their end
Check your Admin Area
Issue: Unable to log in and access the Admin Area
Cause:
Account locked temporarily due to failed renewal attempt
Solution:
Add new payment details directly on the lock screen
Contact the Billing Team at billing@uscreen.tv for further assistance
Check Your Domain
Issue: Your custom domain isn’t working
Cause:
The domain may have expired
Solution:
Check the WHOIS query of your domain and see the expiry
Check if the domain is active through the portal where it is hosted
Cause:
The DNS of the domain isn’t properly connected to the Uscreen servers
Solution:
Verify where your domain is pointing using tools like digwebinterface.com
Check the domain connected in Storefront Domain Settings
If necessary, contact your domain host for assistance
ℹ️ INFO: Refer to our Domain Help Guide for the DNS records required to connect your domain to our servers.
Check the Status Page
Visit our Uscreen Status Page to check for any recent and reported incidents.
💡TIP: If you haven’t already, subscribe to our Status Page to stay informed about any issues or scheduled maintenance.
Check other Websites
Issue: Unable to load any website, such as Google or YouTube
Cause:
A local network or ISP issue
Solution:
Confirm whether the problem is local or regional by testing access to other websites
Check for internet outages on tools like Downdetector
📝 NOTE: Internet outages can affect broad regions, especially during high-stress periods.
Take note of the Error
Rate Limit Exceeded: Temporary error that is usually due to multiple simultaneous requests within a short period
Status Code 4xx: These are client-side errors, often due to incorrect syntax or parameters, missing or misspelled page or element, or invalid authentication
Status Code 5xx: These are server-side errors, often due to transient server connection issues, network congestion, or scheduled maintenance
Contact Uscreen Support
If you've gone through all the steps above and your site is still down, it’s time to contact Uscreen Support. Since you've already exhausted the available troubleshooting options, reaching out now will help us assist you more efficiently.
Provide a screenshot or short recording of the issue
Indicate the URL of the page where you encountered the issue
Mention the error that you received
Share the specs about your device, browser, and the version you've used
Record and save a HAR file and forward it to the support team
🎯 Following these steps ensures a quicker resolution!